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Description: Introduction to 12d Model Data Setup 
  

Level: Fundamental 

  
Outcomes: After completing this module you should understand how to setup and Install 

the Training Data for the Introduction to 12d Model Course. 

INSTALL TRAINING DATA 

To install the Training Data, please download the data from the EXDS website via the following link: 

http://www.exds.com.au/Trainingyou/CourseNotes.aspx 

The data set used in this training session is to be saved on the c:\ drive. 

Once you have downloaded the zip file, open it and extract the files to the c:\drive, the training data will then 
be placed into the correct folders: 

C:\12d\10.00\EXDS_Training\12d-1A_Introduction_to_12d\12d-1A_Introduction_to_12d_Part_1 

C:\12d\10.00\EXDS_Training\12d-1A_Introduction_to_12d\12d-1A_Introduction_to_12d_Part_2 

These folders above are referred to as the ‘Working Folders’ and will contain the 12d Model ‘Projects’. 

The 12d Model data used in this training session is also located in the project folders: 

� 12d Model - .12da file (12d ascii file) 

� AutoCAD - .dwg file (drawing format) 

� AutoCAD - .dxf file (data exchange format) 

� CivilCAD - .as5 file (ascii 5 format) 

All the files for this course are in 2 folders, as we will create 2 Projects in this training course.  

These folders will be the ‘Working Folder’, for the new projects. 

(NOTE: NOT all these files will be used in every course.) 

 

 

 

 

 

 

 

 

 

 

Your folder may look slightly different, but the ‘Working Folders’ will be the  

“12d-1A_Introduction_to_12d_Part_1” and 

“12d-1A_Introduction_to_12d_Part_2” Folders.  

They contains the data set for this course, as well as where the 12d Model projects will be placed. 

Working Folders created after 
extracting the Training Data from the 
Zip File. 
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Description: Project Creation and Management 
  

Level: Fundamental 

  
Outcomes: After completing this module you should understand how to create a new Project 

how 12d Model stores Projects, and how to include Meta Data with your Project. 

CREATE A NEW PROJECT 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Double click on the desktop icon to 
start 12d Model. 

12d Model will start, and show a list 
of the most recently used projects. 

We will not use any of the existing 
projects; instead we will create a 
new project. 

To start a New project click on New 

Type in a new project name. 

You should name your project 
Introduction to 12d Model 

Click the yellow folder button to open 
a browser. 
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Ensure that Create working folder  
is not ticked. 

Press Create. 

Browse to 

12d-1A_Introduction_to_12d_Part_1 

Folder and press Select Folder 

12d Model opens a new project  
with a new plan view. 
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12D MODEL VERSION AND MENU LOCATION 

This is the main menu structure of 12d Model that will be described throughout these course notes: 

 

 

 

 

 

 

 

 

 

 

 

 

 

USING THE MOUSE IN 12D MODEL AND THIS MANUAL 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Left Click 

Press the left mouse button - Pick 

Double Click 

Press the left mouse button twice 
quickly 

Accept 

Press the middle mouse button (or 
wheel) quickly 

Right Click 

Press the right mouse button for 
menu options 

12d Model Version 

The version we are using is 10.0C1b 

12d Model Project Location 

For the current project 

12d Model Main Menu Location 
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PROJECT STORAGE ON YOUR HARD DISK DRIVE 

The data used for this training session is stored in the folders shown below: 

The 12d Model project is stored in the Working Folder 

 

 

 

 

 

 

 

 

 

 

The files inside ‘Introduction_to_12d.project folder’ belong to 12d Model 

DO NOT mess with the files inside the 12d project !! 

 

 

 

 

 

 

 

 

 

 

In this case, the  

12d Model Project is called  

Introduction_to_12d.project 

12d Model projects always have the 
word .project as a suffix 

Introduction to 12d Model Part 2 
Data Set 
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PROJECT DETAILS 

The Project Details panel is displayed when a project is first created.   
It is used to enter metadata relevant to the project. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PROJECT DESCRIPTION 

The Project Description is a place to keep notes about the project.  This allows users to rack changes over 
the history of the project for future reference. 

 

 

 

 

 

 

 

 

 

 

 

 

 
The Project Description will appear 
in the Project Selection panel when 
the project is highlighted. 

Type a description into the white 
area, then press Set 

The Project Details panel opens 
automatically on a new project, and 
can be accessed at anytime using: 

Project => Details => Details 

Metadata entered here can be linked 
to the 12d Title block file and will 
appear on every title sheet, when 
you plot from 12d Model. 

(Additional information specific to a 
particular drawing can be entered 
separately before plotting). 

The Project Description panel is 
opened using: 

Project => Details => Description 

The information that you type into 
the Project description panel  
is shown when you need to select an 
exiting project. 

Finish to close the panel 
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PROJECT DIARY 

The Project Diary is where you can document changes for projects. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When New is selected, a Diary Entry 
is opened and the information can 
be typed in. 

Press Save, so the Entry is saved in 
the Diary. 

Press Save, so the Entry is saved in 
the Diary. 

Press Export to export the Diary 
entries to a document (.rtf) 

The Whole Diary, a selected Month 
or selected Day can be exported 

The Diary allows entries to be added 
for each day. 

The Entries can be added to the 
current day, and also any previous 
days.  

Entries can NOT be added to future 
days in the calendar. 
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Description: Importing CAD Data, Inquiring, Measuring, Navigating and Saving 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to import data into 12d Model, 

control what is displayed on the screen, and do simple inquire and measure 
operations. 

IMPORTING CAD DATA 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

From the Main Menu select: 

File I/O => Data Input => DWG/DXF/DXB. 

Click the folder icon to bring up a list 
of dwg files in the Working Folder 

Choose the file to import into 
12d Model. 

You can double click, or you can 
pick it and press Select 

If the dwg file is not in the  
Working Folder, you can pick 
Browse to find the file on your 
system. 

When you have chosen the file,  
Press Read to import the file into 
12d Model, then Finish to close  
the panel 
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VIEWING DATA 

In 12d Model Layer = Model.  To display models on the view, click the  button, and choose the model 
you wish to see.  You can double click on a single model to display it, or you can select multiple models by 
selecting them from the list.   

The <shift> and <ctrl> keys work in the standard windows way, to select multiple models. 

ADDING MODELS TO A VIEW 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

REMOVING MODELS FROM A VIEW 

 

 

 

 

 

 

 

 

 

 

 

 

Click  to display the ‘Models to 
Add’ list. 

Select the models you wish to display 
and click Select 

Click   to display the ‘Models to 
Remove; list. 

 

Select the models you wish to 
remove and click Select 

In 12d Model a layer is called a 
Model. 

 

The   button is used to add models 
to the view so that you can see them. 

The   button is used to remove 
models from the view so that they are 
not displayed. 

 

Clicking the   button is a useful 
way of seeing which Models are on 
the view. 
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REMOVING MODELS FROM A VIEW BY PICKING 

Another method for removing Models from a view is to click the   with your middle mouse button. 

This will open the Remove Models from View by Pick panel. You can then pick lines from the screen to 
remove a model.  Each time you pick an information panel will appear to give you information about the line 
you have picked.  To remove the model, you must click the middle button to ‘accept’ the line. 

This is a convenient way to remove models from the view if you don’t know the model they are in. 

 

 

 

 

 

 

 

THE ‘VIEW TOOLBAR’ 

Each View in 12d has its own toolbar which control what is displayed on the view, and how it is displayed: 

Plan View 

 

 

Menu  “Master Menu” for this view settings. 

Add Models to View where different models are selected to be displayed on that view. 

Remove Models from View where different models are selected to be removed from that view. 

Zoom Extents will zoom to show the extents of all the data on the view. 

Pan  will allow you to move the data around the view. 

View Zoom allows you to draw a box to zoom into. 

View Shrink allows you to draw a box to zoom out to. 

Zoom Previous will go to the previous zoom area. 

Toggle will allow more information to be displayed (see next page). 

Redraw will refresh the screen after a command. 

Plot  allows you to plot a relevant view. 
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THE TOGGLE BUTTON 

The Toggle Button   changes the information that is displayed in the view. 

� Vertices (Points) can be turned on & off 

� Z Values can be turned on & off 

� Grid can be turned on 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Vertices (Points) 

 

 

 

 

 

 

 

 

 

 

 

Select the Toggle Button 

Then select the Vertices option 

Vertices (points) have been 
toggled on 
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Z Values 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Grid 

 

 

 

 

 

 

 

 

 

 

 

 

 

Vertices (points) and Z Values have 
been toggled on 

The Grid has been toggled on 
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STRING INQUIRE 

Strings => Inquire is a very useful utility, which gives you information about the properties of a string by 
clicking on a string in the plan view.  The F2 button on the keyboard is a shortcut. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Choose Strings=> Inquire 

or Press F2 

then press Pick 

Pick a string 

Extensive information is displayed 
about the string you pick. 

 

When you move the mouse, the 
information panel will close. 
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SNAPS 

When 12d Model is started a snaps toolbars automatically appears under the main menu. 

The snaps panel controls the type of snaps that can be picked from the screen. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A more extensive Snaps panel can opened using: Utilities => Snaps => Snaps 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Point 

Line 

Cursor 

Information 

Point, Line and Cursor snaps 
are the most commonly used 
snaps in 12d Model, and these 
have been assigned to the F3, 
F4 and  F5 keys respectively as 
shortcuts. 

The default 12d Model snaps are 
shown. 

Point and Line to allow you to 
pick point and lines.  

Cursor allows a freehand on-
screen snap, and  

Information gives extensive 
information about the entity that 
you pick. 
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DATA TIP 

Using Strings => Inquire gives extensive information about an entity that you pick. 

An alternative way to display limited information is to use Data Tip. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Data tip can be selected from the 
Snaps panel. 

Data tip can also be selected from 
the Snaps toolbar. 

When you hover the mouse over a 
string or point on the screen, an 
information panel will pop up. 

 

This will remain on the screen until 
the mouse is moved. 

Exercises: 

1. Untick all of the snaps, then try to do a String => Inquire of the strings in the project. 

2. Click Point on, and try again. Toggle Vertices on, so that you can see the points that define the 
strings, and try to snap to one of the string segments. 

3. Click Line on, and try again to snap to one of the segments. 

4. Click Info on, and try again to snap to one of the strings. This time the information about the 
point will be displayed. 
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DISPLAY MANY 

Display many will give information about all of the strings in a 20-pixel radius around the point you pick. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Display Many can also be selected 
from the Snaps toolbar. 

Display Many can be selected from 
the Snaps Panel. 

When you pick on any string a listing 
of all strings in a 20-pixel range is 
displayed 

 

When you pick a line in the panel, the 
relevant string is highlighted, and 
information is displayed. 

 

To accept the selection, double click 
on the line in the panel. 
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MEASURE – BEARING AND DISTANCE 

12d Model provides an easy to use measuring tool for measuring bearing and distance between two points: 

Utilities => Measure => Bearing/Distance 

 

 

 

 

 

 

 

 

 

 

 

 

 

Toolbar Option 

 

 

 

 

 

 

 

 

 

 

 

To measure, pick the start position, 
and accept. 

Then pick the end point and accept. 

The Measure Bearing / Distance 
panel can also be opened from the 
toolbar 

The Measure Bearing / Distance 
panel will display Bearing, Distance 
delta X, Y and Height 

 

If the strings you pick have valid 
heights, the grade and slope of the 
measurement will also be 
calculated. 
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MEASURE – VALUE 

From the Main Menu select:   Utilities => Measure => Value 

 

 

 

 

 

 

 

Then under each Measure Option there is a range of Values that can be measured including: 

X, Y, Z, Chainage, Xfall % 

DX, DY, DZ, Length, Length(3d), Xfall %, Bearing, Angle, Slope 

Commonly used Value Measures are: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Measure Value panel has a 
range of calculations. 

They include selecting: 

� At a Point 

� From Point to Point 

� To a String from a Point 

� From a String to a Point 

At Point = Z Value 

At Point Z Value = 0 
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String to Point = Length 

String to Point, Length = 4.1544m 
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SAVE 

Within 12d Model there are 3 ways to save project data to the hard drive. 

Selecting Save from the Main Menu, Project => Save, will save all data in the project modified since the 
last save. 

Control “S” will do the same as above. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select 
Project => Save 

Select 
Project => Exit 

When Exit is selected from the Main 
Menu, Projects => Exit and a save 
is required, then the Save Project ? 
Yes-no panel is placed on the 
screen. 

If Yes is selected, then 12d Model 
saves the project & exits. 

If No is selected, then 12d Model 
does not save the project & exits. 

If Cancel is selected, then the Exit 
command is aborted and 12d Model 
keeps the project open. 

The Save Project Reminder will be 
displayed as a default every 
15 minutes as a prompt to remind 
you to save your project. 
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Description: Plan Plotting 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create plan plots from 

12d Model. 

PLAN PLOTTING 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pick the plot icon from the Plan View 
toolbar 

Choose Quick Sheet Plot 

Choose pdf_writer and type in the 
name of the pdf file to be created 

Choose a scale of 500 (that is 1:500) 
and a paper size of A4 

Use the Place rectangle button  
to choose the area to be plotted. 

Press the Plot button to create the 
plotted data 
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CHOOSING WHAT TO PLOT 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CHOOSING WHERE TO SEND THE PLOT 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The windows Plotter will send your 
plot to a Windows printer, using the 
windows printer driver. 

If you have a colour printer, the lines 
will be coloured. If you have a black 
& white printer the lines will be 
different shades of grey depending 
on the colour. 

If you have images or aerial photos 
on the view, these will not be plotted. 

The raster and raster_mono 
Plotters work the same way as 
windows and windows_mono but will 
also plot aerial photos. 

Pdf writer – what a good idea 

Use the  and  buttons on the 
view to add and remove models from 
the view you are plotting from. Use 
the toggle button to control the 
display of vertices and string names 
or elevations. 

The plot is a ‘what you see is what 
you get’. 

The plot sheet is shown on the plan 
view, and shows that area to be 
plotted.  The sheet size shown 
depends on paper size and plot 
scale..  If you set a larger sheet, you 
will plot more of the data.  If you 
choose a larger scale (eg 1:100 
instead of 1:500) the detail will be 
large, but you will only get a small 
area of land onto the sheet. 

The position and rotation of the plot 
sheet is controlled using the buttons 
at the bottom of the panel. 

The windows_mono Plotter will 
send your plot to a Windows printer, 
but will force all lines to be black. 

This is usually the best choice if you 
have a black and white printer. 
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The Pdf writer – what a good idea 

We will choose the PDF Writer 

The PDF Writer is smart enough to 
change its settings for different paper  
sizes, you do not need to change any 
settings. 

Ensure the View is correct – this is 
the data that will be plotted. 

Type in the Name for the PDF file. 

Type in the Scale for the Plot, then 
press the enter key. 

Select the Sheet size from the list 

If you do not require a Border and 
Title information for the Plot, Untick. 

Type in Information for the Title if the 
plot into these 2 lines, you can also 
select Text style, Text height and 
Title Colour for the Text and Border. 

Press the Plot button to create the 
PDF, it will be saved to the Working 
folder. 

Use the  button to move the plot 
sheet to the desired location, then 
pick and accept to set the Origin. 

Use the  button to move and 
rotate the plot sheet to the desired 
location, then pick and accept to set 
the Centre Point and Rotation. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 29 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The PDF file has been created. 

When you press Plot, you will be 
warned that the PDF already exists. 

You can: 

- Replace the existing File 

- Cancel to keep the existing File 

- Or go and change the name of the 
   file for a new PDF file. 

To change the plot, here I have 
changed the Scale to 1:500, and 
repositioned the Sheet 
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Description: Loading, Checking, Triangulating Data, and Editing a TIN 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create a TIN (Triangulated 

Irregular Network) in 12d Model. 

CREATE A NEW PROJECT 

The folder: 12d-1A Introduction to 12d Part 2 will be the working folder and the Project will be named 
Barwon Valley 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Project description should included today’s date, your name, the reason for creating the project a brief 
description of how you like your coffee, and anything else that might be relevant.  

The description can be opened again for editing at any time using   Project=>Description. 

Use Project => New to create a new 
12d Model Project 

Type the name of the new project: 
BARWON VALLEY 

Browse to the working folder 

Untick the option  
Create Working Folder 

Type a Project Description here  
(see below) 

Press Create 
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IMPORT DXF DATA 

The data set for this project has been received from the surveyor in a file called Survey.dxf.  

Use:   File I/O=>Data Import=>DXF/DWG/DXB. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click on the yellow folder, and 
choose survey.dxf from the list of 
available files 

Press Read, then press Finish 

The model names all start with the 
word survey . 

Type survey as a prefix for model 
names 

By typing survey  in the Prefix box, 
12d Model will place this text at the 
beginning of the model/s imported 
into the Project. 

This groups them together in the 
Model List and identifies where the 
data has come from. 
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CHECK FOR CROSSING BREAKLINES 

The survey data should be checked for crossing breaklines, and any found should be corrected before the 
TIN is created 

Use:   Tins => Check Breaklines 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Make sure all of the survey data has 
been added to View 1, and then 
choose this view as Data set 1 

Type in the name of a new 
(temporary) model. 
12d will create this model and use it 
to store the results of the Check 
Breaklines operation. 

Use the  button to add the new 
temp model to the screen. 

Crossing breaklines are shown  
 
Use String=>Inquire to find the 
reason for the crossing breaklines. 

Adding models to a view, then 
choosing that view as the Dataset is 
a convenient way to select a group of 
models. 

Views are used often 12d Model to 
select data. 
It is a lot easier to add the required 
data to a view and select that view in 
a panel, than choose a model or 
model list. 

Press the Check button to check the 
crossing breaklines 
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The Information shown are the Co-ordinates for the intersection, along with the Levels of the breaklines at 
the intersection (interpolated levels), then the Model and String Name for the crossing breaklines. 

The survey UG Services Model is listed in all the intersections found, so we need to remove it from the 
View 2 and re-run the Checking Breaklines options. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Use the Output Window to display 
any crossing breaklines that have 
been found. 

Displayed in the Output Window are 
the 8 crossing breaklines that were 
found in the data set. 

Remove survey UG Services Model 
from View 1 and re-run the  
Check Breaklines – but tick on  
Clean models beforehand. 

Clean models beforehand will 
delete the contents of the temp 
model while still leaving the model 
 in the project. 

Press the Check button and the 
diamonds should be deleted from 
View 2. 

The same command can be run on 
any model using Models => Clean 
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Then re-running the check Breaklines will clean the temp model and re-check the remaining models on 
Plan View 2. 

To check that all the clashes were with the survey UG Services Model, refresh the screen and those 
clashes will be removed.  

But also checking Models => Model Information Table is useful to show the contents and details of the 
Model, and by double clicking on the model, it will display the String Information Table and it shows that 
the model is empty – hence no crossing Breaklines. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The temp Model is showing 0 
Elements and Points. 

By double clicking in the temp Model 
above, the String Information Table 
is opened and shows no strings. 
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TRIANGULATE A DATA SET 

A “Triangulated Irregular Network” (TIN) is used to find interpolated elevations at any location on the site. 

Use:   Tins => Create => Triangulate Data 

General Tab 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The additional settings: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Type in a New tin Name we will use 
survey (tin name must be unique), 
then press the Enter key 

The Model name for the new tin will 
be filled out once the Enter key is 
pressed. 

Copy the Model name tin survey to 
the Retriangulate function option 

Preserve strings  

Means that the strings in the project 
will be used as Breaklines in the 
triangulation, always ticked as a 
default. 

Remove Bubbles  

This will remove any flat areas 
created in the tins. Used mainly when 
triangulating contour strings, it means 
that a triangle will not be created with 
the three points connected to the 
same string. 
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Data Tab 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Triangle Data  

Is used when triangulating a set of 
triangle mesh data, this will also turn 
on the Weed Tin which will only use 
1 point where there are multiple 
points at the one location. 

Cell Method  

Is used for really large data sets, in 
the background 12d Model will split 
the data set into smaller sections and 
enable it to process faster, but this 
doesn’t work at it’s best until the 
triangulation reaches 1 million points. 

Select View 2, all of the data we wish 
to use is on View 2. 

The minimum and maximum Z 
values are shown for the data that is 
to be triangulated – a good check! 

This setting will NOT be used with 
the survey data. 

This setting will NOT be used with 
the survey data. 

Choose View 
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Nulling Tab 

Nulling by Angle & Length can be completed within the Triangulate a Data Source Panel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

EDITING THE TIN 

Once the Triangulation is created 12d Model automatically changes the Create Triangulate Panel to the  
Edit Retriangulate Panel, the View Data is changed to a Model List for future reference. 

 

You are able to edit a tin at any time via,   Tins => Edit => Tin 

 

 

 

 

 

 

 

 

 

 

 

12d Model default values that can be 
modified, experiment with different 
length values. Eg 10m and 50m 

To activate the Nulling Tab tick on 
Apply Nulling 

If you have a Polygon surrounding 
the area to Null then you can select 
the string here. 

Press Triangulate to create the Tin 
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Turn our new Model tin survey onto 
the plan view to display the Tin. 

View Data has been changed into a 
Model List for future Reference. 
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NULLING TRIANGLES BY POINTS 

Before we go any further with this tin, we will null (remove) the unnecessary triangles from the Triangulation.  

Use:   Tins => Null => by points 

This option allows single triangles to be nulled (removed) from the triangulation. 

 

 

 

 

 

 

Before the Triangle is nulled. 

 

 

 

 

 

 

 

 

 

 

 

 

After the Triangle is nulled. 

 

 

 

 

 

 

 

 

 

 

 

The Nulling can be continued until all the triangles have been nulled as required. 

Select the Tin from where the 
triangles are to be nulled. 

Select with a Cursor Snap in the 
centre of the triangle to be nulled, 
and Accept the Pick to Null the 
Triangle. 

The selected triangle has been 
nulled, and removed from the 
Triangulation. 

When 12d Model Nulls the Triangles 
they are not deleted, they are merely 
turned off. 
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RESTTING TRIANGLES THAT HAVE BEEN NULLED 

The Null Triangles by Points Panel will also enable you to Reset any triangles that have been Nulled from 
the Triangulation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select Reset to bring back the nulled 
Triangles. 

Select with a Cursor Snap in the 
centre of the nulled triangle, and 
Accept the Pick to Reset the 
Triangle. 

The triangle, has been Reset. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 41 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

NULLING TRIANGLES BY STRINGS 

This option allows multiple triangles to be nulled (removed) from the triangulation at a time. 

Use:   Tins => Null => by strings 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the survey tin to be nulled. 

Right click on the String Option. 

Select the Line option to draw a line 
through the triangles to be nulled. 

Select the Polyline option to draw a 
squiggly line through the triangles to 
be nulled. 

To Increase the speed if this panel 

Tick on Null on accept of strings. 

This means you do not have to press 
the set button for every null. 

Warning: there is no Undo. 

(But you can RESET the triangles – 
see previous page) 

The Line Option 

Hold the Left button down and drag 
the line through the triangles to null. 

Once the line is drawn press the Set 
button to Null the triangles. 

The Polyline Option 

Hold the Left button down and drag 
the polyline around and across the 
triangles to null. 

Once the polyline is drawn press the 
Set button to Null the triangles. 

If you wish to speed up the Nulling 
process, tick Null on accept of String, 
you do not have to press Set every 
time you 
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ADD A BOUNDARY AROUND THE TIN 

When the unacceptable triangles around the edges of the tin have been nulled, we can create a boundary 
around the tin. The boundary will save the settings completed by strings or by points, to be saved if the 
triangulation has to be retriangulated. 

Use:   Tins => Boundary 

 

 

 

 

 

 

 

 

 

 

You are able to edit a tin at any time via, Tins => Edit => Tin 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the survey tin 

Type in the New Model Name. 

Press Create to create the boundary. 

Select the newly created boundary 
string. 

The Tin Boundary can then be used 
in the Retriangulate Tin Panel, by 
selecting it as the Null Polygon, when 
retriangulating the Tin. 

NOTE: If you Retriangulate the TIN 
the nulling you did with Points and 
Strings will be lost. 

The Boundary string set for  
Null Polygon allows you to keep the 
settings. 

All the nulling is completed to the 
selected boundary. 
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ADDITIONAL TOGGLES FOR TINS 

Also experiment with the Tin commands – these are found under the Plan View Toggle Button Menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

There are four options 

� Tin contours 

� Tin edges 

� Tin flow 

� Tin solid 

The Toggle Button  

Tin Contours and Tin Edges 

Tin Flow and Tin Edges 

Tin Solid 

These are great tools for quickly 
viewing the tin on the screen 
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TINS  

The Toggle settings can be changed for the Contours, Edges, Flow Arrows, Mesh, Solid and Tuflow when 
viewing the Tin.  

These can be found under the:   View Menu => Settings => Tins 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

These setting under the View Menu 
will only be associated and applied to 
the current Plan View 

Change the Contour Intervals and 
the Contour Colours here 

Press Set & Finish to activate the 
settings 

Change the Flow Arrow Length and 
the Flow Arrow Colour here 

Press Set & Finish to activate the 
settings 

Or Use F11 on your keyboard 
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Description: Create Contour Strings and Labelling 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create a new Textstyle for use 

in all projects and create Contour Strings and text for a TIN. 

SETUP OF TEXTSTYLE DATA FOR LABELLING CONTOURS 

Create a Textstyle that will be used to label the contours. 

To Create a Textstyle use:   Project => Management => Tree 

 

 

 

 

 

 

 

 

 

 

 

 

 

Under Favourites create a New row and type in the new Textstyle Name = Contour Label 2.5 

 

 

 

 

 

 

 

 

 

 

 

 

 

Double click on the Project to open 
the Project Tree 

Double click Create Textstyle data 
favourite to open the Create/Edit 
Textstyle Panel 

Right click on the Textstyle Data will 
display the menu choices for creating 
a Textstyle 

Press on Edit to open the  
Textstyle Data Editor 
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Select the Textstyle 

Select the Colour 

Select the Height 

Select the Justification 

You can set up as many Textstyle 
Favourites as you like – they need 
to be saved so that they can be 
accessed for all subsequent projects. 

Press the Set button to save the 
Textstyle settings, Finish to close the 
panel 

Press the Set button to save the new 
Textstyle, Finish to close the panel. 

Select the User Folder 

Press Write then Finish 

Textstyles saved to the User Folder 
will be accessible to all projects on 
your computer 
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CREATING CONTOUR STRINGS 

The contours created using the Toggle Button from the View Menu are just display contours;  
they are NOT Contour Strings. 

Display contours cannot be exported or labelled, if you try to do a string inquire you will find you cannot 
select them – that’s because they are not strings. 

To create Contour Strings for export or plotting, go to: Tins => Contour => Contour, Smooth and Label 

Contours Tab 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Major Contours Tab 

 

 

 

 

 

 

 

 

 

 

 

 

Type a function name – this will 
remember all your settings 

Select Tin to Contour 

Type a new Model name,  
(not done elsewhere) 

Contour survey tin 1m Type in the Contour Increment 

Select the Colour 

Type a new Model name, 

Contour survey tin 5m 

Type in the Major Contour Increment 

Select the Colour for Major Contours 

Tick on to create Major Contours,  
(if un-ticked the major contour and 
minor contour strings are saved in 
the same model. 
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Range Tab 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Labels Tab  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Minimum and Maximum Contour 
Level can be specified, if left blank 
the TIN’s minimum and maximum 
values are used 

A Height Range File can be 
selected to colour the contour strings 

Tick on to create Contour Labels, if 
un-ticked no contour labels are 
created. 

See Page 48 an 49 for a full 
description of the Label Methods 

Label Major Contours Only 

Type a new Model name, 

Contour survey tin Labels 

Type the number of Decimal Places 
for the Contour Labels 

Select the Textstyle (previously 
created) 
The Start Distance and Separation 
is the distance along the string the 
label will be placed 

Label start and end will also place 
the contour label at the start and end 
of the string 
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Press Process to create the contour 
strings and labels. 

The created Contours and Labels. 
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Descriptions of the labelling Methods that can be used for contour labelling 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Above Line Contour Direction  

Text is placed above the contour 
string and follows the string direction. 

Above Line Read From Below 

Text is placed above the contour 
string, but is created so it can be 
read from the bottom of the plotted 
sheet. 

Centred Line Read From Below 

Text is centred on the contour string, 
but is created so it can be read from 
the bottom of the plotted sheet. 
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Line Removal and Centre Line 
Read From Below 

Text is centred on the contour string, 
but is created so it can be read from 
the bottom of the plotted sheet. 

The Contour string is removed from 
behind the Label Text. 

Above Line Facing Up Hill 

Text is placed above the contour 
string, but is orientated so it faces 
up-hill. 

Centre Line Facing Up Hill 

Text is centred on the contour string, 
but is orientated so it faces up-hill. 

Line Removal and Centre Line with 
Labels Facing Up Hill 

Text is centred on the contour string, 
but is orientated so it faces up-hill. 

The Contour string is removed from 
behind the Label Text. 
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Description: Exporting Data to CAD 
  

Level: Beginner 

  
Outcomes: After completing this module you should be able to create a new DWG or DXF file 

for use in a CAD program. 

EXPORTING DATA TO CAD 

To Export the Survey Data and Natural Surface Contours to CAD,  

Use:   File I/O => Data output => DWG/DXF/DXB => DWG/DXF/DXB 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Turn all the required models to be 
exported onto the plan view  

Select the Plan View to export the data 

Select the Format for the File 

Type in the new File Name for the 
DWG file 

Select the Dimension – we’ll use the 
2d & contours(3d) 

Press Write to create the DWG file, 
then Finish to finish the Panel 
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The exported Survey Data and Natural Surface Contours shown in CAD below. 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 
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Description: Exercise No.1 – Triangulation and Contour Strings 
  

Level: Beginner 

  
Outcomes: After completing this module you will have reinforced the techniques covered in 

the Introduction to 12d Model (pages 5 to 48) You should be able to import and 
triangulate survey data supplied in CivilCAD .as5 format, create Contour Strings 
and Export to CAD. 

EXERCISE NO. 1 

� Start 12d Model and go to the New Project option. Type in a New Project name and browse to 
C:\12d\10.00\EXDS Training\12d-1A Introduction to 12d\12d-1A Introduction to 12d Part 1 – 
this is the Working Folder.   Start a new project in this folder. 

� Load the CivilCAD ascii file 02170.as5. Use File I/O => Data Input => CivilCAD 

� Turn the Models onto the Plan View. Investigate the models and coordinates of the data.         Use 
Strings => Inquire or the F2 button. 

� Check for crossing Breaklines. Use Tins => Check Breaklines 

� Triangulate the data. Use Tins => Create => Triangulate Data. Use the Nulling Tab to null the 
triangles by Angle and Length when the triangulation is being created. 

� Null by Points or strings. Use Tins => Null => By Points or use Tins => Null => By Strings to 
remove any unnecessary triangles and create a Boundary around the Nulled Triangulation. 

� View the Tin by using the options under the Toggle Button,  Tin Contours, Tin Edges, Tin flow 
and Tin Solid. 

� Create the natural surface contour strings, use Tins => Contour => Contour, Smooth and Label 
select the Major Contour Tab and the Label Tab to complete all in one go. Turn the contour strings 
onto the Plan View. 

� Export the survey and the contours to CAD a .dwg file. Use File I/O => Data Output => 
DWG/DXF/DXB => DWG/DXF/DXB – in the Data to Write panel, select the View (green button), 
View 1, and then fill in the other details. 
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Description: String Creation and Modification 
  

Level: Beginner 

  
Outcomes: After completing this module you should be able to create new Super strings and 

modify the strings by moving, extending, inserting points. Also you should be 
able to Parallel, Offset, Joining and Deleting strings. 

CAD CONTROL BAR 

Fill out the CAD Control Bar before creating any strings, this way their Properties will already be set. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name of the String  

Type a string name or select  
from the list 

Model Name - base 

Is the default but you have the option 
to type a name for the new model or 
select from the model list. 

Colour of the String  

Type in a colour or select from the list. 

H = Height above sea level 

Optional, but you can type in an 
elevation for the points of the string. 

If a height is entered here, all points 
will have this height. 

 

Linestyle 

The default is 1 (continuous) or 
select from the list. 

Weight 

The thickness of the string when 
plotted 

Tinable 

Is the string contourable? 

Same as 

Select a string to populate with its 
properties. 
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STRING CREATION – SUPER STRINGS 

Create a Single String 

Use the CAD Toolbar on the left hand side of the 12d Model screen. 

Click and hold the left button down then move the pointer to the required selection, release the button to 
invoke the selection. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If the String Points are not displayed, 
then the Vertices have not been 
activated as yet on the current Plan 
View, it will be displayed 
Vertices [n/a], once it is activated it 
will display Vertices [on] or [off] 

To create a single line between two 
points, select the 2 Points option. 

Click on the Plan View to create the 
first point on the line. Either an existing 
point or a cursor location (and click the 
middle button to accept) 

Then click on the Plan View where the 
line is to end (and click the middle 
button to accept). 

The 2-point line has been created. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 57 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

Create a Line String 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To Create a Line String (with many 
points), select the Line String option. 

 

This similar to a Polyline in your CAD 
drafting package. 

Start the Line String by clicking on the 
Plan View where the String is to start 
(and click the middle button to accept), 
then click the location of the next point 
(and accept) and continue this process. 

To end the string, press the ESC 
Button. 

When creating or modifying super 
strings from the Toolbars, the  
status bar will always display what  
is required for the command  
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STRING MODIFICATION – POINT EDITS 

Points Append (adding to the End of a String) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Move Points 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the Append Point button, then 
click on the required end of the string 
and accept, then position the cursor 
where the new point/s are required and 
accept. 

Additional Point appended to the end of 
the string 

Select the Move Point button, and then 
click and accept on the point to be 
moved, then select the new position for 
the point and accept. 

Point on the end of the string that was 
moved 

The Append command will add new 
points to either end of the existing 
string. 
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Insert Points (along an existing string segment) 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Add Points Between Points 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To Insert a Point within a segment of 
an existing string, select the Insert 
Point button.  

Click on the segment where the point is 
to be inserted and accept to start the 
insertion, then click at the new location 
and accept. 

Newly Inserted Point along the existing 
string 

Similarly, to Add a Point Between 
Points on a String, select the  

Between Point command and click the 
segment that the point between is to be 
inserted within. 

(NOTE: The existing bearing of the 
existing segment will be kept) 

Newly Inserted Point Between 2 points 
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Inserting Points with Exact Coordinates 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Inserting Points with a known Bearing & Distance 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To locate points when the 
coordinates are known, the Typed 
Input Box can be used.  

Select your command, Create Line, 
the command line is asking ‘pick first 
position’. 

Start typing in the X coordinate and 
the Typed Input Box will appear.  

Enter the X, Y and Z coordinates with 
a space between them (this is the 
delimiter) and press Enter Button  

(if you don’t have a Z coordinate just 
enter the X and Y).  

After creating the first point, a 
bearing and distance measurement 
can be used to produce the next 
point on the string. 

This is achieved by entering the 
prefix of “bd(space)“ to override the 
XYZ coordinate entry in the  
Typed Input Box.  

The bearing and distance can then 
be typed in; the bearing is entered 
with the degrees followed by a 
decimal point, then the minutes and 
seconds.  

The minutes and seconds need to be 
placed in pairs, eg 0505 for five 
minutes and five seconds. 

Eg: 45.5015   ie 45° 50’ 15” 

A space is required to delineate 
between the bearing and distance, 
then the distance can be entered and 
press the Enter Button. 

Note: The Z Values from the Cad 
Control Bar will be used instead of 
the value that you type. To set your 
new Z value make the Cad Control 
Bar blank. 
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Extend Point 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Extend Point (Height) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Extend Point command will 
extend a point, but keep the elevation/s 
unchanged; therefore the slope/grade 
between the two points will change. 

The Bearing of the segment is 
unchanged. 

The Point before it is modified / 
extended 

The Point has been extended, and the 
height has stayed the same 

The Extend Point (Height) command 
will adjust the elevation (height) of the 
point during the extend operation, so 
that the slope/grade of the string will 
remain unchanged. 

Note: Extend Point (Height) is the same 
as Extend but will change the height of 
the extended string. 

The Point before it is modified / 
extended 

The Point has been extended, and the 
height has changed to maintain the 
slope/grade of the segment 
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STRING MODIFICATION – STRING EDITS 

Picking with Direction 

All strings in 12d Model have a start and an end, therefore a chainage 0 and an end chainage. 

 

 

 

 

 

 

 

 

 

 

Positive and Negative Arc Radii 

 

 

 

 

 

 

 

 

 

Positive and Negative Parallel Direction 

 

 

 

 

 

 

 

 

 

Start Chainage 0.000 

End Chainage 699.162 

12d Model uses positive and 
negative values for creating arcs. 

Eg a positive (+) radius is an arc 
created in a clockwise direction, and 
a negative (-) radius is an arc created 
in an anticlockwise direction. 

This positive and negative 
methodology is used for 
offsetting/parallelling strings as well.  

A positive offset value is to the right 
(off the direction of the string), and a 
negative offset value is to the left  
(off the direction of the string). 

+ ve offset 

- ve offset 
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How to use Picking with Direction for Paralleling a String 

This selection method Pick with Direction is extremely useful for a lot of commands within 12d Model.  

You are able to make 12d Model use a direction you specify for a particular command where you need to 
know which side of the string you are offsetting for example.  

This means that you don’t have to find the direction of the string before you start. 

We will use the String Parallel option to explain the process. 

String Parallel – Full 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Pick with Direction over-rides the direction of the string for this single command. 

 

 

 

 

 

 

 

 

To parallel a string select the  
String Parallel command from the 
Toolbar. 

To use Pick with Direction in 
12d Model, hold the left button down 
and move the cursor along the string in 
the direction you would like the string to 
behave. 

Remember that the right side is for a 
positive offset and the left side is for a 
negative offset. 

Then accept the string. 

12d Model’s default is to Parallel the 
FULL string. (If you wish to parallel 
only part of the string then select (p) on 
the keyboard to activate it) We will use 
the default. 

Then enter the Offset distance for the 
parallel string and press the Enter key. 

To Parallel this string we will use  
Pick with Direction. 

The Parallel command continues as 
normal. 
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                                     OR  

 

String Parallel – Partial 

 

 

 

 

 

 

 

 

 

 

 

 

 

Another box is displayed to enter an  
Offset height for the parallelled string  

The Offset height option is to change 
the height of the new string, (leave as 0 
if you don’t require the height/elevation  
to be changed.) the height is a delta 
height difference from the original string

A new string will be created parallel 
and offset to the right based on the 
direction picked along the original 
string. 

If only part of the string needs to be 
parallelled then the Partial (p) needs to 
be entered at the start of the command. 

Use Pick with Direction to select the 
string in the direction you would like the 
string to behave. 

Remember that the right side is for a 
positive offset and the left side is for a 
negative offset. 

Then accept the string. 
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A string will be created and displayed parallel to the selected string but only the length that you selected. 

 

 

 

 

 

 

 

Enter the Offset distance for the 
parallel string and press the Enter key. 

Pick the Start Point for the parallel 
string. 

Pick the End Point for the parallel 
string. 

The Parallel command continues as 
normal. 

Enter the Offset height for the parallel 
string and press the Enter key. 

A new string will be created and 
displayed at the parallel distance 
specified to the selected string. 

NOTE: String Parallel can also be 
assessed from the Main Menu:  

Strings => Strings Edit => Parallel 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 66 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

String Join 

 

 

 

Using the String Join command without using Pick with Direction. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

By using Pick with Direction to select the strings to join, allow the strings to be joined in the method you 
want require. 

 

 

 

 

 

 

 

 

 

 

 

 

Pick String 1 first then String 2. 

To join strings use the String Join 
command from the Toolbar. 

The String Join command joins the 
strings together starting from the  
end of the first string to the start of 
the second string. 

String 1 

String 2 

2 

2

1 

1 

String 1 

String 2 

3 

4 

1 

1 

1 

2 

2 

2 

4 

3 

Pick first string, then the second, with 
Pick with Direction 

The String Join command joins the 
strings together starting from the end of 
the first string to the start of the second 
string except Pick with Direction will 
over-ride the direction of the strings. 

1

2 
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String Join Many 

If you have many strings to join, the String Join Many is a great command where you don’t need to re-
select the first string. Pick with Direction is required to join the strings in the order needed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To join many strings use the  
String Join Many command from  
the Toolbar. 

String 1 

String 2 

String 3 

String 4 

Pick the First string by using Pick with 
Direction 

Pick the Second string by using Pick 
with Direction 

Pick the Third string by using Pick with 
Direction 

Pick the Fourth string by using Pick 
with Direction 

The Join String Many command will 
continue to join as many strings as you 
pick, and will keep asking you to pick 
the next string. 

The strings were picked with the 
direction of the arrows shown. 
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STRING MODIFICATION – USING THE STRING INQUIRE 

To edit strings using the String Inquire command use: Strings => Inquire 

 

 

 

 

 

Vertex/Point Editing 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To edit strings use: 

Strings => Inquire or the F2 Button 

To open the String Inquire panel. 

Firstly pick a vertex (Point Snap – 
remember it is a diamond snap)  
for the point to edit. 

Walk right on the Vertex (number) 

This will reveal the entire vertex 
modifying options available to be 
applied to the point on this string. 

Then Right Click to bring up the 
Pick Options menu for the vertex 
(point) you choose. 

Firstly open the All Above option. 
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Example Height (vertex = ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Point /Vertex Properties for the String 
have been opened in the 1 panel. 

If you select any of these options at the 
top of the list, you will open a small 
panel just for editing that option. 

Modifying options are also available for 
the point/vertex you have picked. 

The Super Vertex Height options allows 
the options 

- No Z 

- Entire String 

- Each Vertex 

These modifying options all allow you 
to apply nothing or a value to the entire 
string or to each individual vertex. 

Always press the APPLY BUTTON 
before moving onto the next vertex or 
it will NOT BE SAVED!!!!! 
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Segment/Line Editing 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Firstly pick a Segment (Line Snap – 
remember it is a square snap)  
for the segment/line to edit. 

If you select any of these options at the 
top of the list, you will open a small 
panel just for editing that option. 

Modifying options are also available for 
the segment/line you have picked. 

Firstly open the All Above option. 

Segment/Line Properties for the String 
have been opened in the 1 panel. 

Always press the APPLY BUTTON 
before moving onto the next segment 
or it will NOT BE SAVED!!!!! 
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DELETE A VERTEX (POINT), A SEGMENT OR A STRING 

Vertex Delete 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Segment Delete 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To delete a Vertex/Point use the  
Vertex Delete command from  
the Toolbar. 

Pick the Point to be deleted 

The Point has been deleted, and the 
string is still joined together. 

To delete a Segment/Line use the  
Segment Delete command from  
the Toolbar. 

Pick a Segment, to delete from the 
string (part of the string between two 
points) then accept. 

NOTE: The string that has the segment 
deleted from it will become two 
separate strings upon accepting the 
Segment Delete option. 

String 1 

String 2 
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String Delete 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

 

To delete a String use the  
String Delete command from  
the Toolbar. 

Pick the String to be deleted 

The entire String has been deleted. 
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UNDO AND REDO COMMANDS 

To Undo or Redo commands in 12d Model Use: 

Edit => Undo (Ctrl Z on keyboard) 

Edit => Redo (Ctrl Y on keyboard) 

The Undo and Redo commands do not UNDO or REDO all options within 12d Model.  
Only changes to the data can be undone (You cannot undo Zooms). 

 

 

 

 

To check what is available to Undo in your 12d Model project, Use: 

Edit => Undo List 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Edit => Redo Command will automatically Redo what has just been undone in the Project. 

Caution must be used when using 
the Undo and Redo commands. 

The Undo List will display the 
commands that are able to be Undone 
within the Project. 

A more useful command is the 3
rd

 
Undo in the Edit Menu will show you a 
prompt for what is going to be undone 
– making sure that you know what is 
going to be undone. 
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Description: CAD Snaps 
  

Level: Beginner 

  
Outcomes: After completing this module you should be able to create Super strings and use 

the CAD Snaps options for placing points in the correct location. 

CAD SNAPS 

The Snaps CAD Toolbar allows a snap to be selected at anytime during a drawing command to assist the 
user place the point in the correct location. 

 

 

 

 

Snaps Offset 

Snaps CAD Offset, this is where a point on a string can be drafted to be a specific distance along an 
existing string to a specific offset from the same string. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Snaps CAD Toolbar 

1. Select the Create Line command, 
pick and accept the  
first point. 

2. Select the Snaps Offset  
from the toolbar. 
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3. Select and accept the string where 
the offset will be measured from. 

4. Select the point on that string that 
the offset will be measured from 
(Control Point). 

5. Type the distance from the Control 
Point along the selected string and 
press Enter. 

New Point created at the offset location 
defined by the values given. 

Offset distance from the selected 
string. 

 

REMEMBER: Positive (right) and 
Negative (left) Offsets Apply here. 

5 3 
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Snaps Mid-Point 

Snaps CAD Midpoint allows a point on a string to be created at the midpoint of 2 other points. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create Line command 

Select Snaps Midpoint from  
the Toolbar. 

Create a String from the midpoint  
of the first string to the midpoint of  
the second string 
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Select points 1 and 2 to find the 
Midpoint. This locates the first point  
of the string. 

First point created midpoint between 
the two points you chose. 

Repeat the Midpoint Snap and then 
select the 2 points where the midpoint 
is to be located for the second point  
of the string. 

The new line is created between the 
midpoint of the first and midpoint of the 
second strings. 

1 

2 

= 

= 

= 

= 
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Snaps Perpendicular 

Snaps CAD Perpendicular, this is where a point on a string can be drafted to be perpendicular from a 
string to a specific point. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create Line command 

Pick and accept the first point of  
the line. 

Select the Perpendicular (p) on the 
keyboard. 

Pick and accept anywhere on the string 
for the second point. 

The second point of the string has been 
created perpendicular to the selected 
string. 
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Snaps Intersection 

Snaps CAD Intersection, this is where a point on a string can be drafted to be at the intersection of two 
other strings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create Line command 

Pick and accept a point on the screen 
for the first point of the line. 

Select the Snaps 2 Segments 
Intersect from the Toolbar. 

Pick & Accept the first segment of  
the intersection. 
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Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Pick & Accept the second segment  
of the intersection. 

Point has been created at the 
intersection of the two segments 
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Snaps Centre 

Snaps CAD Centre, this is where a point on a string can be drafted to be at the centre point of a circle or an 
arc. In this example we will draft a 2 point string to the centre of the 2 points of the two arcs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create Line command 

Select the Snaps Centre from  
the Toolbar. 

First Arc 

Second Arc 

Pick & Accept on the first arc, the point 
will be created 
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Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Select the Snaps Centre from  
the Toolbar.  

To Activate the Snap again for  
the second point it needs to be 
selected again. 

Pick & Accept on the second arc,  
and the point will be created 

The new Line is now created between 
the centre of the 2 arcs 
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Snaps CAD Menu 

The Snaps CAD Menu, is found by Right clicking at the time you require a Snap for placing the proposed 
point. The Snap options are the same on the Toolbar or the Menu Panel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Snaps CAD Toolbars - Docking 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

All the Snap Options are available 
from either the CAD Snap Toolbar 
or the Right Click Menu. 

Snaps CAD Toolbars can be opened 
and placed on the screen in the 
12d Model Projects so they can be 
accessed quickly. 

Snaps CAD Toolbars can also be 
docked on the screen in the 12d Model 
Projects so they can be accessed. 
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Description: TIN Analysis 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to Inquire around the TIN, and 

create Analysis Results for the Slope and Aspect of a TIN. 

SLOPE ANALYSIS – INQUIRING 

The Inquiring options for the TIN are used to determine the Slope, Height and Aspect of a TIN. 

Use:   Tins => Inquire => Slope 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the tin and move the mouse 
across the tin.   

As the cursor is moved about the tin, 
the slope of each triangle is indicated. 

The TIN Slope Inquire is useful to get 
a quick idea of the areas which might 
be suitable for development. 

The Height at any location on the TIN 
can be measure in the same way. 

Use: Tins => Inquire => Height 

The Aspect (direction of fall) of each 
triangle can be measure in the  
same way. 

Use: Tins => Inquire => Aspect 
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ANALYSIS – INQUIRING 

To combine the Inquiring options for the TIN. 

Use:   Tins => Inquire => Tins on a View 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Tin on View Inquire will report  
the height, slope and aspect (direction) 
as you move the mouse across the tin 
in one panel. 
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SLOPE ANALYSIS 

We will use 12d Model’s capabilities for slope analysis to determine a suitable area for creating a building 
platform. 

We would prefer to build our pad on ground with a slope between 3 and 6 percent. 

This will ensure that the adjacent land will drain, and that the pad will be constructed with a minimum 
amount of cut and fill. 

To get a better picture of the likely areas, we will use the Slope Analysis option. 

Use:   Tin => Tin Analysis => Slope => Slope Analysis 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pick the Tin 

Pick the Ground Slope.srf file 

This is supplied with the dataset for the 
course and will be edited in the next 
section. 

Slope Type=Percentage Crossfall=% 

View 2 will be painted with the colours 
from the range file 

(NOTE: Explained on next page) 

Press Slope 
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To see what colours relate to which slope ranges, lets look at the slope range file. 

The .srf (slope range file) can be viewed by clicking on the folder icon and open. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Slope Analysis panel will paint the 
tin based on the slope ranges given in 
the Slope Range file Ground Slope.srf 

Painting the Tin does not save the 
results shown, it is just a viewing tool. 

The colours will disappear when the 
view is refreshed or zoomed. 

Click on the Yellow Folder 

Click on the Open option. 

The file shown in the main panel  
(Slope Analysis) will open for editing. 
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The Slope Range File. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Slope Percentage Crossfalls to shade 
with colour. 

3% - 6% off yellow  

The results of the slope analysis using 
the Slope Range File (.srf) are shown 
above. 

This area looks suitable for the building 
pad construction. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 89 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

To save the Slope Analysis results we will create a new Model and Report file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Report file can be produced if a name is entered for the report.  Do this, and take a look at the report. 

 

 

 

 

 

 

 

 

 

 

New Model = Slope Analysis 

Report file for the results to be 
documented. 

A Polygon can be selected to restrict 
the Analysis within the Polygon. 

The coloured areas are saved if a 
model is given for Model for faces. 

Create a model if you wish to export 
or plot the depth colours. 

Click the Slope button to create the 
colour shading. 
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EXPORTING ANALYSIS RESULTS 

We now need to produce output for drawings or reports. 

The colour faces produced from the slope analysis can be exported as a dwg or a dgn file,  

Use:   File I/O => Data Output.   

Before we export the faces, we will create a legend for the plan. 
Two steps are required for creating a legend:  

Defining a default text style to the used for the legend  

Creating the legend.   

To open the Defaults-Text panel, use   Drafting => Text and Tables => Defaults 

The Defaults – Text panel sets the default text values in this project. 

 

 

 

 

 

 

 

 

 

 

 

Change the default style from ISO to Arial, by clicking on the  button, and choosing Arial from the list. 

Any true font available from Windows can be used, but it is outside the scope of this course to import 
different fonts available in this Project. 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Text will be created in the model  
called Text. 

The Text will be Blue in colour. 

The Text will be 3mm high. 

The Textstyle is ISO. 
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CREATE THE LEGEND – TABULATE RANGE FILE 

To create a Legend, use: Drafting => Text and Tables => Tabulate Range File 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the Range File. 

Select a screen location (x,y) for the 
Legend (Top left corner of table). 

Type in a Heading for the Legend. 

Press Process to create the Legend. 

You can also access the Text 
defaults here under the Font button. 

As can be seen, the text  

Surface Slope Analysis and the % 
sign are brought into the table. 

The colour of the lines around the 
table will be the same as the colour 
of the text. 

The table size is computed from the 
text size.  To change the table size 
you will need to delete it, change the 
text size and recreate it. 

This can be done by Cleaning the 
Model, using: 

Models => Clean 

The location of the table is set by the 
Location xyz field, which fixes the top 
left corner of the table. 
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ASPECT ANALYSIS 

In a similar way to the Slope Analysis option we can calculate the Aspect of a tin surface. 

Use:   Tin => Tin Analysis => Slope => Aspect Analysis 

1. Create an Aspect Range File 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fill out the Aspect Range File as shown below: 

 

 

 

 

 

 

 

 

Select the survey tin. 

Type in the Range file name = 
Aspect.arf 

Select the Yellow Folder. 

Select the folder, and select the  
Open option 

Fill out the Panel as per image. 

Click the Write Button to save the file. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 93 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

2. Create Aspect Analysis 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Report file can be produced if this panel is filled out.  Do this, and take a look at the report. 

 

 

 

 

 

 

 

 

 

New Model = Slope Analysis 

Report file for the results to be 
documented. 

Click the Aspect button to create the 
colour shading. 

The coloured areas are saved if a 
model is given for Model for faces. 

The Model can be exported or 
plotted. 
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Description: Exercise No.2 – Building Pad 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create a Building Pad with an 

Interface (Cut and Fill Batters) to the existing survey TIN. Create a Design TIN, 
and calculate Volumes for Cut and Fill. 

CREATE DESIGN PAD STRING 

We will create a string defining the location of the top of a building pad – we will set up the  
CAD Control Toolbar as per below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Area to create the Building Pad. 
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Create Line String 

We are going to use the CAD lines option to create the southern side of the building pad.   
This string will be located by entering coordinates. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the Create Line option. 

Push the space bar to open the typed 
coordinate input panel. 

Note: that pushing any key will open 
the panel. 

Type the following easting and northing 
coordinates (X) 42750, (Y) 37175 as 
shown, the coordinates are separated 
by a space. 

Note: that a height (Z) does not have to 
be entered. 

Push enter to accept and the first point 
of the string will be created  at the 
coordinates above. 

Point 1 is created 

Push the space bar to open the typed 
coordinate input panel again and we 
will enter a bearing and distance to 
create the second point on the string. 

We need a prefix of bd (space) 

Then enter the bearing of 135° 35’ 05” 
and the distance is 75m, this is 
separated by a space. 

Push enter to accept the second point 
of the string. 

First String has been created 
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String Parallel 

The building pad is going to be a rectangle with a width of 35 metres.   

To create the other side of the building pad we are going to parallel the string to the right by 35 metres. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

String Join 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the Parallel option. 

Use the instructions at the botton left of 
the screen in the staus bar to run you 
through the process. 

Pick the Design pad string to parallel 
(With Direction). 

Choose to parallel the whole string. 

Parallel distance = 35 to parallel to the 
right side of the string.   

Offset height is 0 as the height will be 
the same as the existing string (parent).

Use the String Join option to join the 2 
strings together, remember to use  
Pick with Direction. 

Use the instructions at the botton left of 
the screen in the staus bar to run you 
through the process. 

String has been joined together. 
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String Close 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Section View of Design Pad 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select the Close option. 

Use the instructions at the botton left of 
the screen in the staus bar to run you 
through the process. 

Pick the String and accept to close it. 

The string only has 4 vertices/points. 

The Design Pad at the RL 170.0 

The survey Tin showing the natural 
surface levels. 

The Section cut for the Design Pad. 
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INTERFACE FUNCTION FROM THE PAD TO THE NATURAL SURFACE 

Creating Batters 

To create a batter in 12d we use the Interface function. The Interface function is used to calculate Cut and 
Fill batters from a design string at a design level to a natural surface tin at a specified slope. 

Use:   Design => Apply => Interface 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Interface Function calculates the specified slope at right angles to the control string until either the 
natural surface tin is cut or a fixed (plan) distance is travelled.  

The slope of the line is dependent on whether the control string is below the tin (cut) or above the tin (fill).  

The slope lines are calculated first at the specified section distance, and then the interface string is joined 
together from the end point of the slope lines. 

Fill out a Function Name = Design Pad 

Pick the String to Interface 

Fill out the Slope for Cut and Fill 

Pick the Tin to Interface to = survey 

Fill out the Model for Interface 

Fill out the Model for Slope Lines 

Press Interface to create the Batter 

The Batter has been created all around 
the Design Pad, it is green, which 
means that it is all in Fill. 
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Pad Elevation 

The pad outline that we created currently has a level of 170. 

We will use the F2 button, String Inquire to change the height for the pad. 

We will change the entire string to have a height of 161.50m. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Press the F2 Button and select one of 
the points on the string (at one of the 
corners) make sure that a diamond is 
shown. 

Then right click the mouse to bring up 
the Pick Ops List, walk right on Vertex 
(number) to reveil the Vertex Panel 
and select the Height Option. 
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Set the Height Mode to entire string 
and the height to 161.5m. 

We want to change the Design Pad 
Batters, so that they are calculated at 
1:4 Slopes for both Cut and Fill. 

To get a more detailed interface, 
change the section separation to  
every 2 meters. 

Press the Interface button, every time 
the Interface Function is re-run, the old 
data is deleted and the new modified 
data is recalculated. 

This is one of the great things about 
the function inside 12d 

The Interface Function calculates the 
specified slope at right angles to the 
control string until either the survey 
tin is cut or a fixed (plan) distance is 
travelled – default is 100m. 

After the Interface Function has 
recalculated the specified slope the 
Interface string is created to show 
new batters. 
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Corner Angle 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Interface string is being created, by 
joining to the slope lines, but with 
straight lines, so the corners are not 
modelled correctly…. 

Use: Project => Management => 
Defaults 

The corner angle determines how 
often a section is cut around a 
corner. 

10° was specified here, so the angle 
of the corner 90° is divided by 10° 
and a section is cut at every 9°, so 
there are 9 extra sections cut – 
allowing a better calculation for the 
Design Pad Interface around the 
corner. 

The extra Slope lines have been 
created and the Interface string has 
been joined around, hence a better 
calculation for Volumes. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 102 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

TRIANGULATE THE DESIGN PAD 

To create a Triangulation of the Design: 

 

 

 

 

 

 

 

 

 

Use    Tins => Create => Triangulate Data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Open a new Plan View, and turn the  
3 Design Pad Models onto the view. 

- Design Pad,  

- Design Pad Interface &  

- Design Pad Slope Lines 

On the General Tab: 

Type in New tin Name = Design Pad 

(remember to press enter) so that 12d 
automatically fills out the model as  
tin Design Pad 

Copy and Paste the Model Name into the 
Retriangulate Function field. 

Pick a different colour than the survey tin 

Copy the Model name to the Function 
Name at the top. 

On the Data Tab: 

Pick the Plan View that contains the 
data to be use to create the 
triangulation 
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Perspective View 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: By turning the Survey tin on first, then the Design Pad tin and the Models the Design Pad will be 
displayed on top of the Survey tin. 

On the Nulling Tab: 

Set the Nulling Length to 2m. 

Press Triangulate to create the  
Design Pad tin 

Add the model tin Design Pad to the 
view. 

Open a new Perspective View, and 
turn the following models in the 
order:  

� Survey tin  

� Design Pad tin 

� 3 Design Pad Models 

Use the Toggle Button to turn on 
the Shade option. 
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Description: Section View 
  

Level: Beginner 

  
Outcomes: After completing this module you should be able to create a Section View and 

profile a string and TINS for a Longitudinal or Cross Sectional View of the data. 

SECTION VIEW 

So far the data has been viewed in Plan and Perspective Views, the third type of view in 12d Model is the 
Section View. 

Using the Section View allows the user to do two things: 

View the longitudinal section of ANY string in 12d Model.  
The string that you see in the view is referred to as the PRIMARY STRING. 

View the relative locations of other strings  
WHERE THEY ARE CUT BY THE PRIMARY STRING. 

Open a new Section View, use:   View => New => Section. 

 

 

 

 

 

 

 

NOTE: By highlighting the Plan View (dark blue) before  
Window => Tile Vertical 

the Plan View will sit to the top left corner of the screen. 

Vertical Exaggeration  
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1. Draft a Create Line 2-point String through the Design Pad (remember to fill out the CAD Control 
Bar, Model and Colour etc). 

2. Select the Profile Button from the Section View, then go to the Plan View and pick and accept the 
2-point temporary string.  

3. This string will have a z value of 170, unless you change the CAD Control Bar. 

4. In the Section View, profile the temp string, it’s height of 170 will be shown, then use the Plus 
Button to turn on the Survey tin and Design Pad tin Models (if there is nothing displayed on the 
Section View then press the View Fit Button). 

5. The Vertical Exaggeration Button will allow the vertical exaggeration of the Section View to be 
changed. 

 

 

 

 

 

 

 

NOTE: The Models that you display in the Section View will only  
be shown if the PRIMARY STRING CUTS them.  

Hence you only see data that is relevant to the Primary String 

Profile Button 
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Description: Volume Calculations 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to Calculate both Exact and 

End Area Volumes for the Design Pad and Balance the Design Pad Volumes. 

DESIGN PAD VOLUMES 

Now that we have two tins, we can do a Tin – Tin Volume calculation. 

Use:    Design => Volumes => Exact => Tin to Tin 

This will calculate a volume between the two tins using an ‘exact’ method  
(also called the ‘prismoidal’ method). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

12d Model will calculate the volume within the polygon, and if the tins do not intersect, will assume vertical 
walls between the two tins. 

A depth range file can be used to calculate different depths of fill and cut calculated from the new tin 
surface to the existing tin surface. These depth ranges can also be shaded in a similar manner to the slope 
range file used earlier. 

Important: If a depth range file is used, 12d Model will only calculate the volume for the depth ranges given 
in the file. This can be very useful if you require volumes for cut and fill quantities for different height 
increments. 

 

Use Polygon to restrict the volume 
calculation to within a polygon  

Press the Kite and choose the Interface 
String. 

Press Volume 

Enter a name for the Report file, the 
results will then be documented. 

Select the 2 Tins 
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BALANCED EARTHWORKS 

We are now in a position to balance the earthworks on this job.   
We will move the pad up and down until the cut and fill volumes are equal (or very close). 

At present the volume calculation has produced the following results: 

 

 

 

 

 

Clearly the height of the pad string is too high. 

Use:   Utilities => H-Z => Translate   to move the string down. 

The translate panel is generic, and can be used to translate a string, a model of strings, or all of the data in 
a view etc, and can move the data in the X and Y directions as well as the height Z. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

After the Design Pad data is translated, we need to recalculate the interface function, re-triangulate the tin 
for the pad and recalculate the volumes.  

Cut  -0.093 

Fill  2333.315 

Balance  2333.221 

Pick the Design Pad String 

Type translation values into the dX dY 
dZ panel. (Note: All the dX, dY and dZ 
values are compulsory). 

Use Replace existing data, this will 
translate the string only. 

The data is translated when you press 
the Translate button.   
Press it twice and it will translate the 
data twice (-ve is down). 
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AUTOMATICE PAD BALANCING 

The procedure that we have used before to find a level for the Design Pad – which really requires us to 
guess a pad level, then run three operations to determine the earthworks quantities for that pad level.   

This series of operations has been brought together into a macro.  The macro creates slope lines; interface 
lines, triangulates (and nulls) the interface data and calculates the tin to tin volume.  You can then adjust the 
height of the pad and re-run it again. 

The Macro produces a tin named pad in a model named tin pad.   

It also creates models called pad slope and pad interface. 

Use:  Design => Pads => Dynamic Pad 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this case the pad is clearly too high.  The height increment box is used to translate the pad height up and 
down.  Type -1 into this panel and press ‘Process’.   
The pad has been translated down by 1.0m  
(+ve is up and –ve is down) and the volume recalculated. 

If you press Process again, the pad will be moved down ANOTHER metre, and the volume recalculated. 

Note that the height increment is a relative height change to the pad level, determined by the last height 
increment that was undertaken. 

Note:  Undo will reset the pad to it’s level at the start of the balancing operation. 

Translate will…………… well just try it for yourself ! 

To see the results of your work, open a Perspective Open GL view, and then add the natural surface 
triangulation (tin survey) and the triangulation of the pad (tin pad). 

Fill out the panel as shown 

Press Process and the Interface is 
created, along with the tin, the data is 
added to the view, and volumes are 
calculated. 
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EXERCISE – ALLOW FOR TOPSOIL STRIPPING 

So far all of our Volume calculations have been done assuming that there would be no stripping of topsoil 
from the site.  This is not very realistic and we will now allow for stripping of 200mm of topsoil.   

We will not worry about where this will be stockpiled, or where it will eventually be placed.  The easiest way 
to allow for topsoil stripping is to make a copy of the existing survey tin, and to translate it down by the strip 
depth.   

We can then use the tin of the ‘stripped’ surface for our volume calculations, instead of the existing surface. 

Use Tins => Utilities => Translate/Copy 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Here is a Section View to see the new stripped tin, 200mm below the survey tin. 

 

 

 

 

 

 

 

 

 

 

Pick the survey tin 

Tick to Copy the survey tin 

Type in the new tin name =  
existing 200mm topsoil stripped 

Pick a different colour = brown 

Tick to Translate the survey tin 

using  dx = 0,  

dy = 0  

dz = -0.2m 

Press Process to create the new tin 

Design Pad tin surface 

existing 200mm topsoil stripped  

tin surface 

survey tin surface 
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Description: Exercise No. 3 – Water Quality Basin 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create a Basin with an 

Interface (Cut and Fill Batters) to the existing survey TIN. Create a Design TIN, 
and calculate Volumes for Cut and Fill. 

CREATE A DESIGN WATER QUALITY BASIN LAYOUT 

Water Quality basins generally have two requirements: 

A storage volume.   

A shallow area, where marcophytes can develop. 

Sketch designs have been done for the basin, and an outline of the top and bottom of the deep area has 
been provided. 

Read in the DWG file of the floor of the basin from basin floor outline.dwg. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

DWG file has loaded the two basin 
strings that represent the deep area. 

The Vertices have been toggled 
onto the view. 

Zoom in on the basin and take a look 
at the vertices, which make up the 
strings and the elevations.   

The two strings are 5.0m different in 
elevation. 
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ADDING HEIGHTS TO THE WATER QUALITY BASIN 

The strings from the DWG file need to be converted to Super Strings. 

Use:   Utilities => A-G => Convert => Convert 

 

 

 

 

 

 

 

 

 

 

 

 

 

We will use the F2 button, String Inquire to change the height for the pad. 

We will change the outside string to have a height of 156.50m. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Press the F2 Button and select one of 
the points on the string (at one of the 
vertices) make sure that a diamond is 
shown. 

Select the Model: Design basin floor 

Select the New String Type: Super 

Select Replace existing data 

Press Convert and Finish 
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Now do the same for the inside string, use the String Inquire to set the height to 151.5m 

 

 

 

 

 

 

 

 

 

 

Then right click the mouse to bring up 
the Pick Ops List, walk right on Vertex 
(number) to reveil the Vertex Panel 
and select the Height Option. 

Set the Height Mode to entire string 
and the height to 156.5m. 

Set the Height Mode to entire string 
and the height to 151.5m. 
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Use the Measure Value option under 
the CAD toolbar. 

Measure the Slope between the two 
basic strings to check that the slope is 
1 in 1 (NOTE: the width should be 5m 
and the xfall should be 100%). 

The Slope is 1:1 

Choose String to Point. 

This will measure perpendicularly 
from a string you choose to another 
point. 

If you pick another string you can 
dynamically move the point around 
the other string and see if the Slope 
changes between the 2 strings. 
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TRIANGULATE THE BASIN FLOOR 

Triangulate the basin floor strings.   

Use:   Tins => Create => Triangulate Data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Add the triangulation to the view and 
Toggle on the contours. 

The contours show that the lower part 
of the basin floor is flat (check in a 
section view too), while the intention is 
to have the floor slope evenly from one 
string to the other. 

The triangles also give it away as all 
points are created from the 1 string, 
which has a constant height. 

We will use the Remove Bubbles 
feature of the triangulation operation to 
rearrange the triangles.   

If you have closed the tin panel, this 
can be reopened under 
Tin=>Edit=>Tin.  (We cannot use 
create because the tin already exists). 
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This is due to the chord to arc tolerance, which is set using:   Project=>Management=>Defaults 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tick on Remove Bubbles.  This will 
force 12d to create the triangles using 
two different strings (the three points of 
the triangle can not be from the same 
string if possible). 

These contours better represent the 
desired shape, but there are still some 
incorrect wiggles. 

Note: also that there are triangle 
corners on the curved parts of the 
string, despite there being no points on 
the curves. 

Setting a low chord to arc tolerance will 
create more triangles around the 
curves, and the resulting contours 
being smoothed. 

Set the Chord/Arc Tolerance to 0.01 
(10mm) 

Press Set to use in the project. 

Press Write to save the file for use  
in other projects. 

Retriangulate the Basin and look at the Contours 
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CHECK A SECTION THROUGH THE BASIN 

A section through the tin/basin looks like this. 

Open a new Section View, use:   View => New => Section. 

 

 

1. Draft a Create Line 2-point String through the Design Basin (remember to fill out the CAD Control 
Bar, Model and Colour etc). 

2. Select the Profile Button from the Section View, then go to the Plan View and pick and accept the 
2-point temporary string.  

3. This string will have a z value of 0, unless you change the CAD Control Bar. 

4. In the Section View, profile the temp string, it’s height of 0 will be shown, then use the Plus Button to 
turn on the Survey tin and Design Basin tin Models (if there is nothing displayed on the Section 
View then press the View Fit Button). 

5. The Vertical Exaggeration Button will allow the vertical exaggeration of the Section View to be 
changed. 

 

 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

NOTE: The Models that you display in the Section View will only  
be shown if the PRIMARY STRING CUTS them.  

Hence you only see data that is relevant to the Primary String 
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ADD A SHALLOW AREA TO THE BASIN FLOOR 

We want to add a shallow area to the basin before we create an interface to the surface. 

The shallow area will be 5 metres wide and slope toward the basin at 10% and will be created by paralleling 
(offset) the outer Basin String. 

 

 

 

 

 

 

 

 

 

 

                                     OR 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Strings=>Strings Edit=> Parallel 
command gives you the option of 
giving the string a new name, model 
and colour. If these panels are left 
blank, the new string will copy the 
attributes from the existing string. 

The Parallel option can also be found 
on the CAD Toolbar 

When the string has been paralleled it 
looks like this. 
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To Retriangulate the Design Basin tin use: 

Use:   Tins => Edit => Tin 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The new string has now been included 
in the Triangulation for the Basin. 

The new string for the Design Basin is 
in the same model, so it is an easy 
matter to Retriangulate the tin of the 
basin. 

Press Retriangulate 
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CHECK THE DESIGN BASIN CROSS SECTION 

 

 

 

 

 

 

 

 

 

 

INTERFACE FOR FINAL BASIN BATTER 

Batters will be created to meet the Natural Surface, to do this we will use an Interface function. 

Use:   Design=>Apply=>Interface. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Once the final underwater shape 
has been defined and the TIN 
retriangulated, here it displays the 
new 5m wide planting area in the 
Section View. 

Type in a Function Name. 

Pick the String to Interface from. 

Fill out the Fill and Cut Slopes 

Section separation = 5m 

Select the Tin to Interface too 

Type in the Model names for the 
Interface and the Slope Lines 

Press the Interface button, every time 
the Interface Function is re-run, the old 
data is deleted and the newly modified 
data is recalculated. 
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The resulting interface string and slope 
lines are shown below. 

PROBLEM: The Interface String has 
looped around itself. 

When the Interface string and slope 
lines are long and loop, crossing each 
other – this is a problem as this is not a 
correct solution. 

SOLUTION: The Remove loops 
option needs to be selected and the 
Interface function recalculated. 

SOLUTION: The Remove loops 
option has removed the crossing 
sections and Interface String. 
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INTERFACE FOR FINAL BASIN BATTER 

The newly created Interface string will be used in the tin.  

Use:   Tins => Edit => Tin   to open the Retriangulate Tin Panel 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This string is in the model =  
Design Basin Interface, and we will 
use Tins=>Edit=>Tin to include this 
model in the triangulation. 

Pick the Basin from the tin box and 
then select the Data tab and enter  
the model Design Basin Interface  
in box 2. 

NOTE: You can left click in the box and 
then right click to list all the models in 
the job, and then select the model from 
the list. 

Retriangulate the Tin 

Select the Design Basin tin 
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The updated Basin Tin and contours 

TIN has been updated and is reflected 
by the contours. 

Updated Section View to show the 
Cross section through the Design Basin



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 123 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

FIND THE MAXIMUM WATER LEVEL IN BASIN 

If our existing surface was perfectly flat, we could now calculate the volume for the water to be stored in the 
basin.  The ground is not flat (as shown above), and therefore we need to determine the lowest height on 
the interface string. 

There are a couple of ways to find the lowest level of the interface string. 

Use:    Models=>String Info Table  

Choose the model Design Basin Interface and all the strings contained within that model will be displayed.  
The minimum Z value will shown the maximum water the basin can maintain, before it would overflow. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The other method of finding the minimum level of the basin interface string is to use the  

Project=>Tree, and display the Design Basin Interface model. 

 

 

The Project Tree allows extraction of all the different types of data associated with the project, and utilities 
for setting up text favourites.  

 

The Minimum level of the Design Basin 
Interface string is RL 159.647 

The Line represents the maximum 
water level for the Basin RL 159.647 
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MAXIMUM WATER LEVEL STRING 

Once again the minimum z value for the Design Basin Interface string is RL 159.647m. 

We now wish to create a line on the basin tin at the maximum water level. 

We will have a 300mm freeboard for the basin; therefore the max water level will be RL 159.35m. 

As the water level will be flat, it can be thought of as the contour around the basin tin at RL 159.35. 

Use:  Tin=>Contour=>Contour, Smooth & Label  function to create the single water level contour. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Type in a Function Name. 

Pick the Tin to Contour. 

Fill out the Model for Contours. 

Contour Increment = 1m 

Pick the Colour = dark green. 

The Major Contours and Labels 
tabs cans be turned off by not ticking 
the box at the top. 

Under the Range tab, enter the 
contour minimum, maximum and 
reference as the maximum water 
level of 159.35. 

This will only generate one contour at 
the level of 159.35. 

Press the Process button to create 
the Water Level String 
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VOLUME CALCULATIONS 

Total Volume of Excavation 

The total volume of excavation can be found by doing a Tin to Tin volume calculation. 

Use:   Design=>Volumes=>Exact=>Tin to Tin.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

159.35 RL Contour String 

Original Tin = survey tin 

New Tin = Design Basin tin 

Enter a report file name of  
Design Basin tin to tin.rpt to keep a 
record of the excavation volumes. 

Press Volume to calculate the 
volumes between the 2 tins. 

The Total Cut (c), Fill (f) and  
Balance (b) are listed at the bottom 
of the panel. 
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The Design Basin tin to tin.rpt Report will show the total volumes for Cut, Fill and Balance. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

CUT
Total Excavation of Cut for the Basin 
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TOTAL VOLUME OF WATER STORED 

The total volume of water can be found by doing a Tin to Height volume calculation. 

Use:   Design=>Volumes=>Exact=>Tin to Height. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The cut amount is determined by assuming a vertical wall from the edge of the tin to the user specified 
height. 

 

 

 

 

 

 

 

 

FILL 

CUT 

Pick the Tin = Design Basin 

We know the maximum water level is 
RL 159.35, so we can use the value 
in the panel as shown. 

This calculation assumes that the tin 
Design Basin represents the 
existing ground, and calculates the 
earthworks required making the 
ground flat at the specified level. 

Press the Volume button to calculate 
the volumes. 

The Total Cut (c), Fill (f) and  
Balance (b) are listed at the bottom 
of the panel. 

Enter a report file name of  
Design Basin tin to tin.rpt to keep a 
record of the excavation volumes. 

The fill value is the volume of water 
stored in the basin at a maximum 
water level height of RL. 159.35. 

RL 159.35 
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STORAGE CALCULATIONS 

Depending on the use of the basin, it may be necessary to determine the storage provided at different water 
levels.  This information can easily be obtained using Storage Calcs.   

Use:   Design=>Volumes=>Exact=>Storage Calcs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: Boundary polygons can be used to restrict the extent of a volume calculate to the specific area 
defined by the polygon. We will use the Water Level Contour string we created earlier. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pick the Tin = Design Basin 

Type in the Height min = 151.5 

Type in the Height max = 159.35 

Type in the Increment = 0.2m 

Enter a Report File name 

Select the Polygon, the contour 
string at the water level 159.35 

Press the Volume button to calculate 
the volumes. 

The Total Cut (c), Fill (f) and  
Balance (b) are listed at the bottom 
of the panel. 

Hatched area is the water level at  
RL 159.35 
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As can be seen, the report gives considerable information about the physical dimensions and properties of 
the basin at levels, which increase by 200mm increments. 

 

 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 
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VOLUME CALCULATIONS 

Detailed below is a summary of some of the different volume calculations available inside 12d Model under 
the Exact Volume options. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This method calculates the exact 
volume between two triangulated 
surfaces (tins), or between one 
triangulated surface and a plane of 
constant height. 

The volumes are calculated by 
mathematically subdividing the 
triangles from both tins into areas 
that contain only one triangle from 
each tin. 

In three dimensions, these areas 
represent well-defined polygons with 
the plane of the triangle from one of 
tin as its top and the plan of the 
triangle from the other tin as its 
bottom. 
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Exact Volumes Between Heights 

This option is used to calculate the volume between two heights (height min and height max) on a given tin. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Removal Calculations 

This option will calculate the cut volume from a user specified range of heights to a given tin, for the region 
of the tin exposed by cutting to the height. 

 

 

 

 

 

 

 

 

 

 

Under the Type, you specify if the 
volume calculation will be for fill or 
cut.  If fill is selected then the volume 
figure calculated will be the fill 
volume between the given heights for 
that tin.   

 

The calculation can be restricted to 
within a Polygon, or if no polygon is 
selected the entire tin is used. 

The Cut and Fill between the 2 
Heights is displayed. 

The user specified height range is 
controlled by a height min and max 
and a height increment between the 
min and max.  The plan and slope 
areas are also calculated for each 
height. 

 

The calculation can be restricted to 
within a polygon, or if no polygon is 
selected the entire tin is used. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 132 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

Storage Calculations 

This option will calculate the fill volume from a user specified range of heights to a given tin, for the region of 
the tin filling to the height.  The user specified height range is controlled by a height min and max and a 
height increment between the min and max.   

 

 

 

 

 

 

 

 

 

 

 

Exact Volume from Tin to a Height 

This option will calculate the fill volume from a user specified range of heights to a given tin, for the region of 
the tin filling to the height.  The user specified height range is controlled by a height min and max and a 
height increment between the min and max.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The plan and slope areas of the 
Water Level are calculated for each 
height. 

 

This option is used largely for  
basin storage calculations, as per 
Page 120 of these course notes.   

 

The calculation can be restricted to 
within a polygon, or if no polygon is 
selected the entire tin is used. 

This option is used to calculate the 
volume between a tin and a given 
height.   

 

The calculation can be restricted to 
within a polygon, or if no polygon is 
selected the entire tin is used. 
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Exact Volumes Tin to Height 2 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tin to Height Curve 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This option is used to calculate the 
volume between a tin and a given 
height, but the calculations are 
restricted to only the regions defined 
by another tin rather than the volume 
tin or a polygon. 

 

The calculation is restricted to the 
extent of another tin. 

This option is used to calculate the 
volume between a tin, but between 
minimum and maximum heights and 
writes out a report on the volumes. 

 

The volumes are calculated between 
heights differing by the given 
increment, and writes out a report. 
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Exact Volume Between Tins 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exact Volume Between Tins 2 

 

 

 

 

 

 

 

 

 

 

 

This option is used to calculate the 
volume between two tins using the 
exact method.   

 

This option is probably the most used 
volume calculation option that you 
will use. 

 

The calculation can be restricted to 
within a polygon, or if no polygon is 
selected the entire tin is used. 

This option is used to calculate the 
volume between two tins using the 
exact method but the calculations are 
restricted to only the regions defined 
by another tin rather than to a 
polygon.   

 

The calculation is restricted to the 
extent of another tin. 
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Range File 

The above calculations (apart from the removal and storage calculations) can be produced and reported on 
over a user specified depth ranges. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For example, the cut volumes from the new tin to the original tin will be calculated for the intervals of; 

 

 

 

 

The fill volumes from the new tin to the original tin will be calculated for the intervals of; 

 

 

 

 

Note: The volumes totals are only for the depths in the range file.  If the depth ranges don’t cover the entire 
depth difference then the totals will not be the volume between the two tins.  Therefore, to insure that you 
calculate the entire volumes when using a range file, it is recommended that the final interval is large 
enough to include all depths (a interval of 999 metres was used in the range file above).   

As shown in the picture, the fill 
ranges are positive and the cut 
ranges are negative from the new  
tin surface. 

This is an example of a depth range 
file.  The negative values are cut 
depth intervals from the new tin 
surface and the positive values are 
fill depth values from the new tin. 

If the above range file was used in a 
tin to tin calculation, volume 
calculates and a report file will be 
produced for the different cut and fill 
intervals specified in the range file. 

As shown in the picture, the fill 
ranges are positive and the cut 
ranges are negative from the new  
tin surface. 

-999 to –2 metre interval from the new tin. 

–2 to –1  metre interval from the new tin. 

-1 to 0 metre interval from the new tin. 

0 to 1 metre interval from the new tin. 

1 to 2  metre interval from the new tin. 

2 to 3 metre interval from the new tin. 

3 to 999 metre interval from the new tin. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 136 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

 

Description: Exercise No.4 – Additional Exercises 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to modify Super Strings to 

change them to the required shape. 

ADDITIONAL EXERCISES 

Read in the 12da File, exercises.12da into the project. 

Use:   File I/O => Data Input => 12da/4da Data 
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These exercises are to reinforce the commands required to set up the boxing strings from the road design 
strings. 

Picking with Direction is an extremely useful tool especially with the following options we are going to use 
to set up the boxing strings. Note, the top of the examples is the finished strings. When pick with direction 
isn’t used when selecting strings, 12d uses the original direction of the string. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise Number 1 – String Join. 
The aim of this exercise is to join the 
strings in the configuration shown, by 
using the pick with direction method. 

Exercise Number 2 – Fillet/Arc. 
The aim of this exercise is to create 
Fillets/Arcs in the required quarter of 
the cross shown, using the pick with 
direction method is the quickest way 
to achieve this. 

Exercise Number 3 – String Split. 
The aim of this exercise is to split the 
string perpendicular to a specific 
point. 

Exercise Number 4 – String Join 
and Point Delete. The aim of this 
exercise is to join the strings in the 
configuration shown, and not have 
any extra and unnecessary points on 
the string. 

Exercise Number 5 – Intersection 
Strings. The aim of this exercise is 
to use the previous commands to 
create the edge of road strings 
needed to create boxing/subgrade 
strings. 
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EXERCISE NUMBER 1 – JOIN STRING MANY 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Use the String Join Many command 
under the Cad String Toolbar. 

Then follow the instructions on the 
status bar (this is at the bottom left 
corner of 12d Model) 

This is the Solution, the finished 
joined string 

This is the Start of the exercise, 
with 5 individual strings, you need to 
join them together using pick with 
direction. 

Once you have pick the first string, 
12d will then ask you to pick the next 
string. 

Here is the last string being selected 
to join the 5 strings together. 
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EXERCISE NUMBER 2 – FILLET / ARC 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  

Positive Radii are drawn in a clockwise 
direction and negative radii are drawn in 

an anticlockwise direction. 

Use the Fillet command under the 
Cad Arcs Toolbar. 

Then follow the instructions on the 
status bar (this is at the bottom left 
corner of 12d Model) 

The Arrows are showing the 
direction for the segment to depart 
from 

The Arrows are showing the 
direction for the segment to arrive to 

Enter the Radius and Press Enter 

The Solution, an Arc in each 
quadrant. 
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EXERCISE NUMBER 3 – STRING SPLIT 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Use the String Split command under 
the Cad String Toolbar. 

Then follow the instructions on the 
status bar (this is at the bottom left 
corner of 12d Model) 

This is the Solution, the finished 
Split string 

This is the Start of the exercise, 
with 2 strings, you need to split the 
top one at the end of the Arc. 

There are now 2 strings, after the 
original string was split at the end of 
the arc. 
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EXERCISE NUMBER 4 – STRING SPLIT 

This exercise is going to look at joining the strings without any extra points. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Using the String Join and  

Vertex Delete commands. 

These are the 2 areas where the 
strings have duplicate points, these 
duplicate points need to be removed 
before the 3 strings can be joined 
together. 

Use the Vertex Delete command 
under the Cad Delete Toolbar. 

Then follow the instructions on the 
status bar (this is at the bottom left 
corner of 12d Model) 

Delete the duplicate points from 
strings 1 and 3, so they look like this. 
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Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Use the String Join Many command 
under the Cad String Toolbar. 

Then follow the instructions on the 
status bar (this is at the bottom left 
corner of 12d Model) 

Select the first string with direction. 

Then select the next 2 strings to join 
the 3 strings to 1 string. 

The joined string should only have 7 
vertices, as shown. 
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EXERCISE NUMBER 5 – INTERSECTION STRINGS 

The aim of this exercise is to use the previous commands to create the edge of road strings required to 
create boxing/subgrade strings.  

Using the String Split, Vertex Delete, and String Join commands. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 

2 3 

4 

Firstly Split the through carriageway 
string at the end of the kerb fillets, 
creating 3 separate strings, as 
shown. 

Delete the first vertices on strings 1, 
2, 3 & 4 by using the Vertex Delete 
so there is a clear definition between 
the strings  
(they are the vertices next to the kerb 
fillets). 
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Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Using String Join Many now join the 
3 strings on each carriageway to 
create a singular string as shown (the 
strings are generally joined in the 
direction of the way a motorist would 
drive around the corner of the 
intersection). 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 145 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

 

Description: Exercise No.5 – Boxing / Sub-grade Development 
  

Level: Fundamental 

  
Outcomes: After completing this module you should be able to create Sub-grade Pavement 

Strings to Triangulate. These are used to calculate the Volumes of new pavement. 

BOXING / SUB-GRADE DEVELOPMENT OVERVIEW 

Boxing is excavation of the subgrade required to allow a road pavement (concrete or gravel) to be built to 
the finished design levels.  12d Model will allow users to apply boxing as part of a road template, and this 
refinement allows bulk earthworks quantities to be accurately calculated. 

It can also allow the designer to provide the builder with level information for the subgrade construction. 

Boxing should be thought of as a series of copied cross sections commands, beneath the road finished 
surface level and joined to produce a surface or surfaces. 

 

CREATING BOXING / SUB-GRADE STRINGS 

Import a 12da file called road vol.12da  

Use:   File I/O => Data Input => 12da/4da Data 

Turn off the Lot Bdys and tin Ex surf from the view as shown. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Road Design String Models 
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We need to create Cross Sections from these Road Design Strings. 

Use:   Design => X-Sections => X-sections from cuts through strings 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pick the View that has the Road 
Design turned onto. 

 

Section Separation = 10m 

 

Left Cut Width = 50m 

Right Cut Width = 50m 

 

Model for cuts = Road 2 Sections 

 

Colour for Cuts = Blue 

 

Select CL = Road 2 

Press Cut to create the Cross 
Sections 

Then Select the Road 1 CL and cut 
the Cross Sections for Road 1 

The data to cut the cross sections 
from are the Road and Kerb Return 
Strings along with the Alignments. 
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Open a New Section View, use:   View => New => Section 

 

 

 

 

 

 

 

 

TRIANGULATE THE DESIGN DATA 

The Road Design now needs to have a triangulation created to form a surface for the Road Design. 

Use:   Tins => Create => Triangulate Data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Notes: 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

___________________________________________________________________________________ 

Profile one of the Road Section 
strings as shown. 

The Ex surf tin has also been added 
to the view. 

Use the Road Design Data, strings 
and sections to create the 
triangulated surface. 
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CREATE THE STRIPPED SURFACE 

Next a Stripped surface of 100mm Topsoil removal is required. 

Use:   Tins => Utilities => Translate/copy 

This panel allows you to copy an existing triangulation and translate it all within one panel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select Old Tin = Ex Surf 

 

Copy the Tin = Yes 
Type in a New Tin name, press 
Enter, then pick a colour. 

 

Translate the Tin = Yes 
dx = 0 
dy = 0 
dz = -0.1 

Press Process to create the new 
Translated Tin 

Stripped 100mm Tin 
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CREATING THE SUB-GRADE PAVEMENT DESIGN 

The Sub-grade pavement design will be a thickness of 450mm. 

To create the Sub-grade pavement strings we will use:   Utilities => H-Z => Translate  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

We will use the Filter Button to 
select the data. 

Use the String Info Tab to select the 
required data to translate. 

Select all the Orange Strings 

Select Filter Select – the found 
strings will be highlighted on the 
screen, plus the number of elements 
selected and shown at the bottom of 
the Panel 

Enter the Delta X, Y and Z as shown. 

Use the Pick Button if you want to 
measure the values from the screen. 

Copy to Model = Subgrade Strings 
(type in a new model name) 

Press the Translate Button to copy 
and translate the data. 

Translated Road Design Strings 

Now to amend these strings to be 3 
lip of kerb strings.  
The strings need to be Split, and 
Joined to form the 3 strings. 
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The Road Centreline strings are a special type of string called a Super Alignment and can be translated 
using the Super Alignment Translate option. Super Alignments cannot be translated in the usual way like 
Super strings or polylines. 

Use:   Strings => SA Tools => Translate 

 

 

 

 

 

 

 

 

 

 

 

NOTE: You can refer back to the 
exercises in Exercise 4 to see 
examples of how to Split and Join 
Strings. 

When you profile the Sections and 
turn on the “Subgrade Strings” Model 
you can see the translated strings. 

Pick the Super Alignment String 

 

Type in the Delta Height for the 
pavement thickness 
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Move the 2 Super Alignments that have been translated (as they were translated into the original model) 

into the Subgrade Strings Model. 

 

 

 

 

 

 

 

 

 

The Pavement Design will be comparable to the sketch below: 

 

 

 

 

 

 

 

 

The Translated Super Alignment has 
been added to the Subgrade Strings 
Model. 
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Now the lip of kerb strings need to be paralleled 1 metre to represent the base of the kerb. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Use the String Parallel from the  
Cad String Toolbar. 

Parallel the Subgrade kerb strings by 
1m and a delta height difference of 
0m height. 

Parallelled strings under the kerb. 



 

 

 

Introduction to 12d Model 

12d Model April 2013 Page- 153 -  
Civil and Surveying Software 
Distributed by Extra Dimension Solutions 

 

Extra Dimension Solutions 

Now to finalise the pavement strings we need to calculate where the pavement will interface with the design 
road surface, somewhere on the footpath above the paralleled strings. 

We will use the Interface Function, so we will use:   Design => Apply => Interface 

We will set up 3 Interface functions, 1 for each edge of the subgrade pavement. These strings will be near 
vertical with a slope of 1 to 0.001 and will interface to the Road Design tin. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Function Name: Subgrade 1 

Pick the newly parallelled Subgrade 
strings 

Cut Slope = 0.001 

Fill Slope = 0.001 

Section Separation = 1m 

Tin = Road Design 

Model for Interface = Subgrade 
Strings 

Interface Strings now taken up to the 
Design Section. 
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We now have the required strings to calculate the subgrade volume calculations, so we can create a 
triangulation of the subgrade surface.  

Use:   Tin => Create => Triangulate Data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Triangulation of the Subgrade Strings 
Model. 

The new Subgrade Tin can then be 
turned onto the Section View and see 
that it matches the Subgrade strings 
we created. 
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With this new Subgrade surface we can then calculate the pavement volumes for the road design. 

Use:   Design => Volumes => Exact => Tin to Tin 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The volumes can then be calculated between the: 

� Ex surf tin and Ex surf Stripped 100mm tin for the topsoil stripping volume 

� Ex surf Stripped 100mm tin and Subgrade tin for the excavation quantities to get the site ready 
for the pavement to be constructed. 

� Subgrade tin and Road Design tin to calculate the amount of pavement material required for the 
Road Design. 
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Appendix – Description of the Training Data 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create “Introduction to 12d” Project 

� Import “belm1mar01.dwg” AutoCAD Drawing. 

� Add the imported data onto the Plan View. 

� Toggle on the Vertices, Vertex Indices, and z values. 

� Measure Tools. 

� Plan Plotting to a Printer, a Model and an AutoCAD Drawing. 

� Project Description Panel 

Alternative Create “Introduction to 12d” Project 

� Import “103001.as5” CivilCAD File. 

� Add the imported data onto the Plan View. 

� Toggle on the Vertices, Vertex Indices, and z values. 

� Measure Tools. 

� Plan Plotting to a Printer, a Model and an AutoCAD Drawing. 

� Project Description Panel 

� Triangulate the survey data, then look at the Nulling by angle and length. 

Create “Barwon” Project 

� Import “Survey.dxf” file. 

� Check Crossing Breaklines in the survey data. 

� Create a Triangulation called tin survey and Null the long triangles. 

� Create a tin boundary. 

� Use the tin toggles to view the tin toggle options, tin contours, tin flow and tin solid. 

� Create Contour Strings. 

� Export survey data and contour strings to AutoCAD. 

Exercise No. 1 

� Triangulation and Contour Strings 

String Creation & Modification 

� Create Line, and Line Strings. 

� Move points, insert points, extending points and add points between points.  

� Add points with exact coordinates, and bearing and distances.  

� Pick with Direction 

� Adjust string height with the F2 Button. 

� String Parallel, String Join and Join Many. 

� Delete a string, segment and vertex. 

� Undo and Redo Commands. 

� Snaps CAD Toolbar with Offsets, Midpoints, Perpendicular, Intersection and Centre. 
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Tin Analysis 

� Slope Analysis Inquiring. 

� Create Slope Analysis data of the Barwon Data Triangulation. 

� Exporting Slope Analysis Results. 

� Tabulate Range File – Creating a Legend. 

� Aspect Analysis - Creating. 

Exercise No. 2 – Building Pad 

� Open the “Barwon” Project again. 

� Create Building Pad outline. 

� Interface Function to create the Cut and Fill Batters to the Natural Surface Tin. 

� Adjust the height of the string (F2 Button). 

� Re-run the Interface Function. 

� Add Corner Angle in the Project Defaults. 

� Create new Plan View and Add the 3 Design Pad Models. 

� Triangulate the Design Pad. 

� Open a Perspective View & turn on the NS tin, Design Pad tin & Design Pad Models. 

� Open a Section View, draft a line through the Design Pad and Profile the 2 tins. 

Exercise No. 3 – Water Quality Basin 

� Open the “Barwon” Project again. 

� Import the Basin Floor strings – basin floor.12da. 

� Interface Function to create the Cut and Fill Batters to the Natural Surface Tin. 

� Adjust the height of the string (F2 Button). 

� Re-run the Interface Function. 

� Add Corner Angle in the Project Defaults. 

� Create new Plan View and Add the 3 Design Pad Models. 

� Triangulate the Design Pad. 

� Open a Perspective View & turn on the NS tin, Design Pad tin & Design Pad Models. 

� Open a Section View, draft a line through the Design Pad and Profile the 2 tins. 

Appendix A – Additional Exercises 

� Import the Exercises.12da file. 

� Follow the exercises for additional picking with direction. 

Appendix B – Boxing/Sub-grade Development 

� Import the Road vol.12da file. 

� Cut Cross Sections of the Design strings. Create a Design tin. 

� Translate and copy the survey tin to show the stripping surface. 

� Translate the lok strings, join them together and translate the Alignment CL strings. 

� Parallel the translated lok strings for under the kerb area 

� Interface back to Design surface tin. 

� Create a tin of the Subgrade and calculate volumes for the subgrade. 


